Sign in to follow this  
Followers 0
admin

CURRENT SITUATION with the WEBSITE

7 posts in this topic

Sorting out the several thousand photographs from our old website in order to include them in the new one isn't going to plan. All the images are there, none have been lost, but they're all mixed up together with no indication of whom they belong to. It's all going to have to be done by individually sorting them and then individually attaching them to the correct posts. To make matters worse, each photograph is named using a combination of letters and numbers - perhaps 20 or more - so trying to sort through them by sight makes you go dizzy! To makes matters worse still, they're arranged in 3 different folders and some folders contain duplicates of images in others.

Here's a screenshot of what you're probably seeing at the moment. That image reference number is for the old forum and I'm going to have to manually amend every single one of them - thousands!

images01.jpg

There is a simpler way, if you could call it that, by editing every single reference to each photo so that it points back to the old website but that would mean having to keep two forums running and updated all the time. I don't want that - we need everything together in one forum because that's the whole idea of this.

On top of the images conundrum there are several other issues I am having to deal with. Firstly there's the YouTube images added during the old forum. The ones added using just a few characters between YouTube 'tags' are simply not displaying but that's okay - I can sort those easily enough. The YouTube videos added using a direct link to YouTube are each displaying at least twice with one small video above one or two larger ones and they're the devil to delete.

Another problem I've discovered is that almost every opening post has the remainder of a 'Poll' attached immediately before the post. I'm having to edit every opening post just to delete that poll question and remove the unwanted bar and brackets.

poll01.jpg

I went to bed last night (or should I say early this morning) and I'd almost resigned myself to giving up. I don't want to make myself ill and this kind of thing is sure to lead down that pathway. But this morning I feel better about it. It's going to take me a long time to put things right - much longer than I had anticipated, but please just keep using the forum and keep it ticking over whilst I sort things out.

Share this post


Link to post
Share on other sites

I forgot to mention the problem with all the thousands of quotes added throughout the website. Look below:

quote01.jpg

Every single one has the quoted text 'struckthrough' so each one has to be edited.

 

Share this post


Link to post
Share on other sites

Okay, so I've continued working my way through the most popular forums - the ones that see regular interest. I've done some of our layout threads and completed the entire Workbench & Members Loco's & Rolling Stock categories. Wherever possible I've copied images from the old forum and added them again as attachments on the new one. It's become clear that almost every attached image has been inserted twice on almost all threads other than Tony's 'Camdale Layout' thread where they appear three times! I've deleted all the duplicates which must be a great relief to the server!

I've uploaded a few of my images to albums in the new Gallery so that it doesn't remain empty for too long. From my brief and limited experience with the new forum software I'm coming to the conclusion that where you wish to include images within forum posts it is better to add them as attachments and use the Gallery simply as a Gallery for displaying photos of your work. If you have a lot of images in the Gallery then going through the list to find the ones to attach to a forum post can take some doing - but it's not impossible.

I may decide to archive any threads that have been unused for some time. There seems little point in spending time reformatting those that might never see the light of day again. Perhaps I'll just leave them until the original author returns to them?

I have no date set for when the old forum will cease to be accessible but please ensure you have copies of any photographs you might wish to save. I will maintain copies here but they'll only be ones that have been resized for display on the forum.

Share this post


Link to post
Share on other sites

There's been very little user activity on the forum whilst I've been messing around with it but as I've already said, don't let that put you off. I would really like everyone to embrace the new software - it's much better than before, really. The whole appearance is improved, inserting links adds a more professional feel, and attaching photos is straightforward too. There's absolutely no reason why anything should ever have to change again so feel free to add what you wish. Use the Gallery to highlight your construction or your workbench activities - the Gallery especially is very much improved on what we had to manage with before.

As for what I've managed to complete so far, well I've now done just about every thread in the 'Garden Railway Techniques' section and reattached all missing images. I'm sure many of the posts will never see any further activity but they're done anyway - it makes the forum appear lived in. I'll continue making my way through the other sections until all missing images have been reinstated.

There's still quite a number of Members Layout threads to deal with but as they usually contain the most posts I've still done just the main ones. I'll do others as and when I can but I may decide to archive some of the older less-used ones unless the owner comes forward before that time arrives.

Share this post


Link to post
Share on other sites

I have now done just about all I'm going to do with the older threads. I think every single category, other than our 'Members Garden Layouts' has been gone through and all images reattached, strilke-through text removed, and those non-existant 'poll' questions deleted. I'm not sure that all previously user-added links will work but I'm not too concerned about those. At least we have our forum back up and running as before but now with a much improved user interface. As I've mentioned before, usually when there's a major change of software the easiest way is to start over from scratch with a completely blank board but I'm pleased to say we've managed to keep it all together.

As for the remainder of the 'Members Garden Layouts', I will probably see to those if they see further use. I'm almost certain I have done all our most popular threads. I've spent a week or so now going through the entire forum and I've think I must have reviewed almost every single post ever posted and every single photo ever attached. It's been a headache to be honest, but I have so enjoyed looking back over what we've all done and it's thanks to you all for being part of it and sharing what you've been up to.

I'm looking forward to seeing what more you are able to add.

Share this post


Link to post
Share on other sites

Can I just make everyone aware that it will be necessary in the near future to remove all images from our old Photo Gallery in order to save server space. I do have copies of all the images that members have uploaded but they are all in one single batch without any indication of ownership other than the actual image itself.

Please note that removing the old Photo Gallery will not affect the images included in any posts on this new forum - either recently made or those posted years ago . I have just made sure that, where images were previously linked to the old Photo Gallery, they have now been included as attachments.

Where users have previously made posts which included images not located on our forum (i.e photo's on Photobox or other online storage sites etc) then they have been left as they were.

I would add that having worked my way through the whole site, it is much better if you include images as attachments to your posts rather than linking to them located elsewhere but that's for you to decide.

Share this post


Link to post
Share on other sites

The website upgrade is now fully complete. I have removed all files associated with the old forum in order to maintain security of the website and replaced the new forum back into the root of the domain so that the forum is once again accessible directly from www.oogardenrailway.co.uk.

I have added a redirect so that anyone attempting to access using www.oogardenrailway.co.uk/forum/ will be helped along their way. I'll leave that in place for a short time to give everyone chance to discover the changes.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0